(2012/08/23 12:26), SASADA Koichi wrote:
> I use "untrace/retrace" because tracer is active after
> TracePoint.trace{}.  I want to emphasize trace *again* by "untrace".

Oops.  I use "retrace" to emphasize *again*.


----

I also think we need reconsidering "TracePoint" name.

Now, TracePoint object have two functionality.

(1) Trace control

"start and stop" tracing. #trace, #untrace.

(2) Trace status snapshot

Get current status.  #event, #line, #file, #biding


You can see this mixture by the following code.

  tracer = TracePoint.trace(){
    p tracer.binding  # (2)
  }
  ...
  tracer.untrace # (1)

BTW tracer.binding out from tracer block causes an exception.

Maybe the name "TracePoint" by trans is for (2).

-- 
// SASADA Koichi at atdot dot net