(2012/08/23 5:04), Eric Hodel wrote:
> On Aug 20, 2012, at 00:10, ko1 (Koichi Sasada) <redmine / ruby-lang.org> wrote:
>>  trace.untrace # stop tracing
>>  ...
>>  trace.retrace # restart tracing
> 
> I think start/stop or on/off (like tracer.rb) are preferable to having "trace" twice on the same line.
> 

I use "untrace/retrace" because tracer is active after
TracePoint.trace{}.  I want to emphasize trace *again* by "untrace".


I agree "on/off" naming if we accept TracePoint.new API. like:

  trace = TracePoint.new(...){...} # not activated
  ...
  trace.on
  ...
  trace.off

or

  trace.activate{
    ...
  }

-- 
// SASADA Koichi at atdot dot net