Oh my, what a disaster. I wonder who made the crazy decision that hash
slice would returned a slice of the hash and slice! would return... the
receiver and not the slice of the hash. Especially since Array slice and
slice! return the same values...

So, sorry Michael, I was confused. Anyways, I think the most important is
`slice` and that's the correct name too, and it might be nice to have a
mutating version too. I'd name it slice! and too bad for ActiveRecord, but
that might not be the best way to go.

-- 
<lay trum/>