> It's definitely like extract! in ActiveSupport, just non-destructive.


There is no "extract!" in ActiveSupport, its "slice!" you mean.

So yeah, I've used that before, and would be nice in core. I think it
should be called 'slice' instead of 'extract'. It's a better name and it
already exists like that in ActiveSupport and in Facets...

-- 
<lay trum/>