On Fri, Aug 10, 2012 at 4:25 PM, matz (Yukihiro Matsumoto)
<m... / ruby-lang.org> wrote:
> __id__ returns object_id number, identity here is supposed to return itself.
> I agree with introducing method to return self, but not fully satisfied with the name 'identity'.
> Any opinion?

How about allowing Object#tap to take no block, simply returning self?
This syntactic sugar would allow

    this.tap

instead of

    this.tap {}

If a new method must be added, please for the love of sanity don't
call it id or identity or identifier. This space already chronically
overloaded by frameworks, the need for entities to have publically
visible identity notwithstanding.

Perhaps __object__, which would feel natural to anyone already
familiar with __id__? Failing that, Object#object, although I'd expect
this to break a fair amount of existing code. :-(

Ciao,
Sheldon.