Issue #6815 has been updated by naruse (Yui NARUSE).


r36458 extends an API, Psych::Emitter.new(io) to Psych::Emitter.new(io, options = Psych::Emitter::OPTIONS).
Such change shouldn't be in patch release.
Additional to say generally such change shouldn't be in teeny release like 1.3.3->1.3.4.
See also http://semver.org/

Anyway, it seems too late and seems not reasonable importing different one, so you can backport them at this time.
----------------------------------------
Backport #6815: Backport Psych 1.3.3 and 1.3.4 to stable branch
https://bugs.ruby-lang.org/issues/6815#change-28564

Author: tenderlovemaking (Aaron Patterson)
Status: Open
Priority: Normal
Assignee: 
Category: 
Target version: 


Hi, I'd like to backport Psych 1.3.3 and 1.3.4 to the ruby_1_9_3 branch.  It's 10 commits:

  r36583, r36458, r36414, r36103, r35690, r35681, r35658, r35657, r35655, r35492

I've attached a patch.  Can someone please review?  Thank you!


-- 
http://bugs.ruby-lang.org/