Issue #6737 has been updated by trans (Thomas Sawyer).


@dbrian In part I wanted to submit this on it's own merits as well. I hesitated to even bring up #6442. I personally find having word forms for "symbol" methods a good thing in itself because they have semantic value and read better, which is nice in certain cases. Admittedly its sort of an aesthetics suggestion --where as we have #store as a equivalent for #[]=, I'd like to see #read for #[]. 

An all-in-one patch would be quite extensive. It's not about adding four methods, it's about adjusting every other method to utilize them.





----------------------------------------
Feature #6737: Add Hash#read and alias as #[].
https://bugs.ruby-lang.org/issues/6737#change-28143

Author: trans (Thomas Sawyer)
Status: Feedback
Priority: Normal
Assignee: 
Category: core
Target version: 2.0.0


Just, generally speaking it is nice to have a word named method for things when that suites readability better. Most operators (outside of numerical math, of course) have word equivalents. I actually hope you will accept this request based on this merit alone.

But more specifically this is also related to #6442, "CRUDifying" Hash's design. Adding #read is essentially the first step in doing this. Since #read, being the "R" in CRUD, would be one of the core methods, its preferable to have word-named method to go along with other methods, #store (for create and update) and #delete to act as that foundation.

Obviously there is nothing earth shattering here, just asking for an alias at this point. I'd like to incrementally submit requests/patches to "CRUDify" Hash rather then submit one huge patch as it will be much easier to test and ensure backward compatibility that way.



-- 
http://bugs.ruby-lang.org/