"dpg (Dan Gailey)" <dan.p.gailey / gmail.com> wrote:
> Target version: 
> ruby -v: ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux]
> 
> 
> Ruby segfaults in abstract_mysql_adapter.rb:241 when trying to run a simple command from the command-line.
> 
> the command: 
> /bin/bash -l -c 'cd /var/www/schoolyard/releases/20120710202724 && script/rails runner -e production "Email.invite"'
> 
> ruby -v:
> ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux]
> 
> command output error log:
> 
> $ /bin/bash -l -c 'cd /var/www/schoolyard/releases/20120710202724 && script/rails runner -e production "Email.invite"'
> /var/www/schoolyard/shared/bundle/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/abstract_mysql_adapter.rb:241: [BUG] Segmentation fault
> ruby 1.9.2p0 (2010-08-18 revision 29036) [x86_64-linux]

  ^^^^^^^^^^^^

Are you mixing library versions?