Issue #6673 has been reported by luislavena (Luis Lavena).

----------------------------------------
Bug #6673: No longer able to run tests in parallel (-j2)
https://bugs.ruby-lang.org/issues/6673

Author: luislavena (Luis Lavena)
Status: Open
Priority: Low
Assignee: 
Category: test
Target version: 2.0.0
ruby -v: ruby 2.0.0dev [i386-mingw32] at r36254


=begin
Hello,

Since a few revisions back, I'm no longer able to run tests in parallel, getting output like the following:

 # Running tests:
 
 [666/690] 116=test_utils 4824=test_err_in_callbackC:/Users/Worker/Code/ruby/ruby/lib/mkmf.rb:75:in `split':  invalid byte sequence in UTF-8 (ArgumentError)
         from C:/Users/Worker/Code/ruby/ruby/lib/mkmf.rb:75:in `block in <module:MakeMakefile>'
         from C:/Users/Worker/Code/ruby/ruby/lib/mkmf.rb:74:in `each'
         from C:/Users/Worker/Code/ruby/ruby/lib/mkmf.rb:74:in `<module:MakeMakefile>'
         from C:/Users/Worker/Code/ruby/ruby/lib/mkmf.rb:42:in `<top (required)>'
         from C:/Users/Worker/Code/ruby/ruby/lib/rubygems/custom_require.rb:36:in `require'
         from C:/Users/Worker/Code/ruby/ruby/lib/rubygems/custom_require.rb:36:in `require'
         from C:/Users/Worker/Code/ruby/ruby/test/win32ole/test_err_in_callback.rb:11:in `<top (required)>'
         from C:/Users/Worker/Code/ruby/ruby/lib/rubygems/custom_require.rb:36:in `require'
         from C:/Users/Worker/Code/ruby/ruby/lib/rubygems/custom_require.rb:36:in `require'
         from C:/Users/Worker/Code/ruby/ruby/lib/test/unit/parallel.rb:114:in `run'
         from C:/Users/Worker/Code/ruby/ruby/lib/test/unit/parallel.rb:177:in `<main>'
 Some worker was crashed. It seems ruby interpreter's bug
 or, a bug of test/unit/parallel.rb. try again without -j
 option.

This was working previously, even on Windows (the platform I'm reporting right now)

Base Ruby is 1.9.3-p194 [i386-mingw32]
Target Ruby is ruby 2.0.0dev (2012-06-29) [i386-mingw32] at r36254

=end


-- 
http://bugs.ruby-lang.org/