Issue #6624 has been updated by shyouhei (Shyouhei Urabe).

Status changed from Open to Feedback

Yes this is a nice feature to have.  But last time I tried to backport it was not that trivial (at least to me).

So I'd like to see someone actually create a patch against the actual 1.8.x sourcecode.
----------------------------------------
Bug #6624: require_relative in 1.8
https://bugs.ruby-lang.org/issues/6624#change-27356

Author: shevegen (markus heiler)
Status: Feedback
Priority: Low
Assignee: 
Category: 
Target version: 
ruby -v: 1.8.7 (latest patch)


Hi!

I know there is little chance that this will be included, as this month is now last
chance for any change in 1.8.x, as 1.8.x is dead, but still I suggest it. :)

Some things like lambda -> operator won't have an alternative for 1.8, so it
is not even possible to make all changes for 1.8.x anyway in backward compatible
way.

But one thing that could perhaps have a 1.8.x version is require_relative, and
it is used a lot in 1.9.x

Folks could i.e. avoid the -> lambda, but still make use of require_relative,
and their gems would work on 1.8.x too.

The absolute filepath could be found out perhaps via

Pathname(__FILE__).dirname.realpath

Hmm ok I know this has no chance to make it, no problem :)

I am on 1.9.3 finally myself!


-- 
http://bugs.ruby-lang.org/