Issue #5096 has been updated by drbrain (Eric Hodel).

File syslog.logger.patch added

This updated patch removes references to rails and the silence method (as it is not thread-safe).
----------------------------------------
Feature #5096: offer Logger-compatibility for syslog ext
https://bugs.ruby-lang.org/issues/5096#change-26648

Author: normalperson (Eric Wong)
Status: Assigned
Priority: Low
Assignee: drbrain (Eric Hodel)
Category: 
Target version: 


There's http://rubygems.org/gems/SyslogLogger, but I would like to have
ths compatibility by default.  Having to remember to install the
oddly-capitalized SyslogLogger gem makes things harder than it should
be.

Importing the SyslogLogger gem would solve this issue.


-- 
http://bugs.ruby-lang.org/