Issue #6421 has been reported by djberg96 (Daniel Berger).

----------------------------------------
Feature #6421: Add zlibwapi to extconf.rb file for zlib library
https://bugs.ruby-lang.org/issues/6421

Author: djberg96 (Daniel Berger)
Status: Open
Priority: Normal
Assignee: 
Category: ext
Target version: 1.9.3


The vstudio contrib solution in zlib 1.2.7 creates a "zlibwapi" dll file. According to the readme.txt file, "The new DLL was renamed because there exist several incompatible versions of zlib.dll on the Internet."

So, I propose this very modest adjustment to the extconf.rb file for zlib:

-if %w'z libz zlib1 zlib zdll'.find {|z| have_library(z, 'deflateReset')} and
+if %w'z libz zlib1 zlib zdll zlibwapi'.find {|z| have_library(z, 'deflateReset')} and

Regards,

Dan


-- 
http://bugs.ruby-lang.org/