Issue #6402 has been updated by MartinBosslet (Martin Bosslet).


By the way, since there are a couple of OpenSSL-related issues floating around right now - could you please help me summarize so that I can get a better overview whether there are open issues that would need to be addressed in Ruby's OpenSSL?

Several issues seem to have turned up in https://github.com/rubygems/rubygems/issues/319. One bug was definitely related to a modification of OpenSSL itself introduced by Ubuntu 12.04 which has been fixed by now.

But regarding the problem on OS X, there seemed to be several issues causing similar but unrelated problems. There was one problem related to RubyGems server settings, which has been fixed. Were there also problems related to what nobu fixed with this patch? Are there other open issues on OS X that yet remain to be identified?

The first reactions seemed to imply that upgrading to 1.0.1 would somehow fix the issues, but I doubt it, especially in the case where certificate validation failed.
----------------------------------------
Backport #6402: backport fixes for [ruby-core:44755]
https://bugs.ruby-lang.org/issues/6402#change-26467

Author: tenderlovemaking (Aaron Patterson)
Status: Open
Priority: Normal
Assignee: 
Category: 
Target version: 


Hi, we should backport the changes for [ruby-core:44755] to the 1.9.3 branch.  I've attached a patch.  Can someone (nobu or martin) please review and I'll apply to the 1.9.3 branch?

Thanks!


-- 
http://bugs.ruby-lang.org/