Issue #6221 has been updated by akr (Akira Tanaka).


I committed the patch.

Note that the link I shown needs user and pass parameters as:
http://rt.openssl.org/Ticket/Display.html?id=2769&user=guest&pass=guest
----------------------------------------
Bug #6221: OpenSSL 1.0.1 is breaking the drb test suite
https://bugs.ruby-lang.org/issues/6221#change-26097

Author: bkabrda (Bohuslav Kabrda)
Status: Closed
Priority: Normal
Assignee: seki (Masatoshi Seki)
Category: 
Target version: 1.9.3
ruby -v: ruby 1.9.3p125 (2011-10-30) [x86_64-linux]


Hi,
I'm having problem with running drb_ssl tests with Ruby 1.9.3.p125 and OpenSSL 1.0.1, originally reported at [1]. Martin Bosslet told me to open this new issue for drb_ssl. So here is the problem:

$ make test-all TESTS="test/drb/test_drbssl.rb"
/builddir/build/BUILD/ruby-1.9.3-p125/lib/drb/ssl.rb:185: warning: SSL_accept returned=1 errno=0 state=SSLv3 write key exchange A: EVP lib (OpenSSL::SSL::SSLError)
(I previously set config[:verbose] = true in ut_array_drbssl.rb, to see this message.)

I'm reproduce this on Fedora 17/rawhide only with OpenSSL 1.0.1.

Thanks!

[1] https://bugs.ruby-lang.org/issues/6089#note-9


-- 
http://bugs.ruby-lang.org/