Issue #5455 has been updated by nahi (Hiroshi Nakamura).

Assignee set to matz (Yukihiro Matsumoto)
Target version deleted (3.0)

I guess Endoh-san postponed the decision to 3.0 dev cycle, but please allow me to try a bit more now.

If removing $SAFE in 3.0 (or something, the version incompatible with 2.0) is acceptable, is it possible to deprecate it in 2.0?  Warn $SAFE usage with -w I mean.

Matz, do you think we can decide it (removal and deprecation) now?
----------------------------------------
Feature #5455: $SAFE should be removed
https://bugs.ruby-lang.org/issues/5455#change-25590

Author: kosaki (Motohiro KOSAKI)
Status: Open
Priority: Normal
Assignee: matz (Yukihiro Matsumoto)
Category: 
Target version: 


see

[ruby-dev:44554]
[ruby-dev:44572] 



-- 
http://bugs.ruby-lang.org/