Issue #6227 has been reported by jonforums (Jon Forums).

----------------------------------------
Bug #6227: [mingw] openssl backport causing test error
https://bugs.ruby-lang.org/issues/6227

Author: jonforums (Jon Forums)
Status: Open
Priority: Normal
Assignee: MartinBosslet (Martin Bosslet)
Category: ext
Target version: 1.9.3
ruby -v: ruby 1.9.3p172 (2012-03-30 revision 35179) [i386-mingw32]


On Win7 32bit built with MinGW GCC 4.6.2 and the RubyInstaller build recipes, the following error occurs:


sh-3.1$ ruby --version
ruby 1.9.3p172 (2012-03-30 revision 35179) [i386-mingw32]

sh-3.1$ ruby -ropenssl -e 'puts OpenSSL::OPENSSL_VERSION'
OpenSSL 1.0.0h 12 Mar 2012

sh-3.1$ make test-all TESTS='openssl fiddle psych zlib io json mkmf pathname stringio erb 
fileutils ruby/test_io.rb ruby/test_io_m17n.rb ruby/test_file.rb'

  1) Error:
test_multibyte_read_write(OpenSSL::TestSSL):
OpenSSL::SSL::SSLError: SSL_read:: internal error
    c:/projects/rubyinstaller-git/sandbox/ruby19_build/.ext/common/openssl/buffering.rb:53:in `sysread'
    c:/projects/rubyinstaller-git/sandbox/ruby19_build/.ext/common/openssl/buffering.rb:53:in `fill_rbuff'
    c:/projects/rubyinstaller-git/sandbox/ruby19_build/.ext/common/openssl/buffering.rb:94:in `read'
    c:/Users/Jon/Documents/RubyDev/ruby-git/test/openssl/test_ssl.rb:407:in `block (2 levels) in test_multibyte_read_write'
    c:/Users/Jon/Documents/RubyDev/ruby-git/test/openssl/utils.rb:235:in `call'
    c:/Users/Jon/Documents/RubyDev/ruby-git/test/openssl/utils.rb:235:in `block (2 levels) in server_loop'


-- 
http://bugs.ruby-lang.org/