On Fri, Mar 30, 2012 at 16:02, matz (Yukihiro Matsumoto)
<matz / ruby-lang.org> wrote:

> OK, you think negative for include? is special. Understood.
> But as Nikolai pointed out, exclude? is not the best name for the function.
> Any alternative?

How about changing the definition of Enumerable#none?, #any?, and
#all? to take an optional argument that is compared against each
element using #==.  Then we have

if File.exist? some_file and some_list.none? some_file

I would not write it like that  I”Ēd still use not a.include? b, which
I think is hard to beat  but then we at least don”Ēt need to come up
with a new name and these three methods gain semantics that I”Ēve felt
they were lacking.