Issue #5555 has been updated by matz (Yukihiro Matsumoto).

Status changed from Feedback to Rejected

The basic naming for methods in standard class libraries are:

* use basic form (include not includes)
* put question mark for predicates
* put bang mark for "dangerous" version of methods

"is_a" and "has_key" are exceptions.  "is_a" (or "isa") used very often for inheritance in OO context.
"has_key" has already been deprecated by "key?"

Besides that, backward incompatibility introduced by renaming them would be unbearable.


Matz.
----------------------------------------
Feature #5555: rename #include? to #includes?
https://bugs.ruby-lang.org/issues/5555#change-25274

Author: alexeymuranov (Alexey Muranov)
Status: Rejected
Priority: Low
Assignee: matz (Yukihiro Matsumoto)
Category: 
Target version: 


Shouldn't the #include? method be renamed to #includes? ?
I think this will be closer to correct English and consistent with #has_key? method (not #have_key?).


-- 
http://bugs.ruby-lang.org/