Issue #5555 has been updated by mame (Yusuke Endoh).

Status changed from Open to Feedback
Assignee set to matz (Yukihiro Matsumoto)
Priority changed from Normal to Low

Hello,

2011/11/13 Alexey Muranov <muranov / math.univ-toulouse.fr>:
> Good explanation. ??The method names can also me viewed as #(does_it_)include?

I'm not sure but the rule seems Lisp's name convention?
Maybe it also came from Lisp (has-key-p).


> However, #has_key? then needs to be renamed to or aliased as #have_key?.

Unak-san told me that there is another example: #is_a?.
I guess is_* and has_* are just two exceptions; they are accepted
idiomatic expressions.  Do you really want #have_key? and #be_a?


> I also like the anonymous suggestion to require 'english_grammar' :).

You can start by yourself with gem :-)

-- 
Yusuke Endoh <mame / tsg.ne.jp>
----------------------------------------
Feature #5555: rename #include? to #includes?
https://bugs.ruby-lang.org/issues/5555#change-25245

Author: alexeymuranov (Alexey Muranov)
Status: Feedback
Priority: Low
Assignee: matz (Yukihiro Matsumoto)
Category: 
Target version: 


Shouldn't the #include? method be renamed to #includes? ?
I think this will be closer to correct English and consistent with #has_key? method (not #have_key?).


-- 
http://bugs.ruby-lang.org/