Hello,

2012/3/27 Yusuke Endoh <mame / tsg.ne.jp>:
>> So I prefer the current behavior.
>
> I agree with you, as a core team member.
> It is a simple and straightforward implementation.
> But I also agree with Benoit, as a user.
> The output is actually a bit verbose.
>
> I guess the fault is the prefix "#<Enumerator::Lazy: ".
> It is too long and unfriendly for human eyes.

Hmm...could you make a counter proposal?  We may be able to choose a
shorter prefix such as "#<lazy", in which case, however, the class
name information would be lost.

-- 
Shugo Maeda