Issue #3727 has been updated by shyouhei.

Status changed from Feedback to Closed

closing because no feedback..
----------------------------------------
Feature #3727: rb_f_require_relative not included in Ruby API
https://bugs.ruby-lang.org/issues/3727#change-24739

Author: jeffshantz
Status: Closed
Priority: Normal
Assignee: 
Category: 
Target version: 


=begin
 Now that Ruby no longer includes the current directory in $: as of Ruby 1.9.2, those of us using the C API cannot use rb_require() to require a file in the same directory as our native code without adding the current directory to $:.
 
 However, since this is not a good practice, we should be able to access rb_f_require_relative() from the C API.  Unfortunately, this function is defined in load.c, but is not available in any files within /usr/local/include/ruby.
 
 I believe this function, or perhaps a function named rb_require_relative() (to be consistent with the C API naming conventions) should be added to ruby.h.  
 
 My apologies if there is something that I have missed.
=end



-- 
http://bugs.ruby-lang.org/