Issue #5619 has been updated by Kenta Murata.

Target version changed from 1.9.3 to 2.0.0
ruby -v changed from - to ruby 2.0.0dev (2012-03-10 trunk 34964) [x86_64-darwin11.3.0]


----------------------------------------
Bug #5619: Segfault on OS X
https://bugs.ruby-lang.org/issues/5619

Author: Otto Hilska
Status: Open
Priority: Normal
Assignee: Kenta Murata
Category: 
Target version: 2.0.0
ruby -v: ruby 2.0.0dev (2012-03-10 trunk 34964) [x86_64-darwin11.3.0]


When I run 'roadie' gem specs on OS X, Ruby 1.9.3p0 segfaults.

Here's how to reproduce:

$ rvm use 1.9.3
$ git clone git://github.com/Mange/roadie.git
$ cd roadie
$ bundle install
$ bundle exec rake

I've attached the command output and the crash report.

It seems it might be a nokogiri issue, but since nokogiri's own tests run fine, I'm not sure.

This is my environment:

$ uname -a
Darwin becherovkax.local 11.2.0 Darwin Kernel Version 11.2.0: Tue Aug  9 20:54:00 PDT 2011; root:xnu-1699.24.8~1/RELEASE_X86_64 x86_64
$ ruby -v
ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-darwin11.2.0]

It also happens with current 1.9.3-head (installed from RVM):
ruby 1.9.3p0 (2011-11-08 revision 33661) [x86_64-darwin11.2.0]

However, everything works fine on Linux.


-- 
http://bugs.ruby-lang.org/