Issue #5096 has been updated by Aaron Patterson.

File sysloglogger.patch added

I've attached a patch.  It imports sysloglogger as Syslog::Logger.  Syslog::Logger is a logger that logs to Syslog, but has the same API as Logger.
----------------------------------------
Feature #5096: offer Logger-compatibility for syslog ext
https://bugs.ruby-lang.org/issues/5096

Author: Eric Wong
Status: Open
Priority: Low
Assignee: Eric Hodel
Category: 
Target version: 


There's http://rubygems.org/gems/SyslogLogger, but I would like to have
ths compatibility by default.  Having to remember to install the
oddly-capitalized SyslogLogger gem makes things harder than it should
be.

Importing the SyslogLogger gem would solve this issue.


-- 
http://bugs.ruby-lang.org/