Issue #6040 has been updated by Yui NARUSE.


Luis Lavena wrote:
> On Thu, Feb 16, 2012 at 9:55 PM, Yui NARUSE <naruse / airemix.jp> wrote:
>  >
>  > Issue #6040 has been updated by Yui NARUSE.
>  >
>  > Status changed from Open to Closed
>  >
>  > This should be fixed r34650 in trunk / 1.9.3-p127.
>  > Could you check and reopen this if not fixed?
>  
>  Sorry, redmine seems to be down so responding to ruby-core directly.
>  
>  ruby_1_9_3, revision 34660 worked perfectly. Thank you.
>  
>  This justifies another patchlevel release? Big5 encoding seems
>  important for eastern languages (chinese) and RubyInstaller seems to
>  have some userbase there (along with Japan).

This affect only on packaging.
So I repacked it.
----------------------------------------
Bug #6040: Transcoding test failure: Big5 to UTF8 not defined (MinGW)
https://bugs.ruby-lang.org/issues/6040

Author: Luis Lavena
Status: Closed
Priority: Normal
Assignee: Yui NARUSE
Category: build
Target version: 1.9.3
ruby -v: ruby 1.9.3p125 (2012-02-16) [i386-mingw32]


Hello,

While testing 1.9.3-p125 (released), discovered this bug which was not present in previous builds:

<pre>
100) Error:
test_Big5(TestTranscode):
Encoding::UndefinedConversionError: "\xA1@" from Big5 to UTF-8
    C:/Users/Luis/Projects/oss/oneclick/rubyinstaller/sandbox/ruby_1_9/test/ruby/test_transcode.rb:54:in `encode'
    C:/Users/Luis/Projects/oss/oneclick/rubyinstaller/sandbox/ruby_1_9/test/ruby/test_transcode.rb:54:in `check_both_ways'
    C:/Users/Luis/Projects/oss/oneclick/rubyinstaller/sandbox/ruby_1_9/test/ruby/test_transcode.rb:1788:in `test_Big5'
</pre>

I can't reproduce this when run in isolation (make test-all TESTS="ruby/test_transcode.rb")

Perhaps this is a fluke?

Thank you



-- 
http://bugs.ruby-lang.org/