Issue #1122 has been updated by Yusuke Endoh.

Assignee changed from Yukihiro Matsumoto to Narihiro Nakamura

@nari: There is no strong objection about the name "try".
Did matz hate "try"?  If not, it is okay to go ahead.


@runpaint: We need matz's opinion about the name, as OP
said.


I, personally, objected the API design of this proposal in
[ruby-core:21907] (and I still hate send-like API), but I,
as a release manager, must say that my personal objection
is negligible, if matz approved send-like API and does not
agree with me.

-- 
Yusuke Endoh <mame / tsg.ne.jp>
----------------------------------------
Feature #1122: request for: Object#try
https://bugs.ruby-lang.org/issues/1122

Author: Narihiro Nakamura
Status: Assigned
Priority: Normal
Assignee: Narihiro Nakamura
Category: core
Target version: 2.0.0


=begin
 Hi.
 
 Object#try is new feature of rails2.3.
 
 http://guides.rubyonrails.org/2_3_release_notes.html
 http://github.com/rails/rails/blob/master/activesupport/lib/active_support/core_ext/try.rb
 http://ozmm.org/posts/try.html
 
 Matz said: "OK, good name is the last problem."
 
 Anyone has better name?
 
 thanks.
 
 ---
 Narihiro Nakamura
=end



-- 
http://bugs.ruby-lang.org/