Em 30-01-2012 14:27, Roger Pack escreveu:
>>> and related
>>> String#first(n)
>>>
>>> Feedback welcome.  If none I'll file it on redmine with a patch.
>>> -roger-
>> I like the idea. I'm just not sure if 'last' would be clear enough...
>> Don't have another suggestion for now, sorry...
> Hmm.  I was thinking "first" and "last" would be good since they would
> match Array#last and Array#first but maybe something like first_chars
> or something?

I find first_chars and last_chars much more readable. But that is my 
personal opinion, feel free to check with others too.