> To remove original DL completely, we have to bundle libffi itself
> wholly.

Why?

Example, openssl is really important and rubygems and some modules
strongly depend on it. but we don't bundle libopenssl itself. What's
different?