Issue #5826 has been updated by Ayumu AIZAWA.

File 0001-RUBY_API_VERSION-2.0.0.patch added


----------------------------------------
Feature #5826: When the RUBY API_VERSION will be increased?
https://bugs.ruby-lang.org/issues/5826

Author: Ayumu AIZAWA
Status: Open
Priority: Normal
Assignee: 
Category: core
Target version: 2.0.0


I think RUBY_API_VERSION should be 2.0.0 for Ruby2.0.0.
In other hand, some people might think it should stay 1.9.1 becouse Ruby2.0.0 will have backward compatibility with 1.9.

----

--- include/ruby/version.h
+++ include/ruby/version.h
@@ -30,9 +30,9 @@
 #define RUBY_BIRTH_DAY 24
 
 /* API version */
-#define RUBY_API_VERSION_MAJOR 1
-#define RUBY_API_VERSION_MINOR 9
-#define RUBY_API_VERSION_TEENY 1
+#define RUBY_API_VERSION_MAJOR 2
+#define RUBY_API_VERSION_MINOR 0
+#define RUBY_API_VERSION_TEENY 0
 #define RUBY_API_VERSION_CODE (RUBY_API_VERSION_MAJOR*10000+RUBY_API_VERSION_MINOR*100+RUBY_API_VERSION_TEENY)
 
 #ifdef RUBY_EXTERN



-- 
http://redmine.ruby-lang.org