Issue #5756 has been updated by Shota Fukumori.

ruby -v changed from 1.9.3.dev to ruby 1.9.3dev (2011-09-23 revision 33323) [x86_64-darwin10.6.0]

take a log doing like this: `ruby aaa.rb|&tee crash.log` or `ruby aaa.rb 2>&1 >crash.log`
----------------------------------------
Bug #5756: crashs when Twitter.update_with_media with rails
http://redmine.ruby-lang.org/issues/5756

Author: SungHee Kang
Status: Feedback
Priority: Normal
Assignee: 
Category: 
Target version: 
ruby -v: ruby 1.9.3dev (2011-09-23 revision 33323) [x86_64-darwin10.6.0]


I'm using the Ruby 1.9.3dev and Ruby on Rails 3.1.3
When I use twitter gem and call 'Twitter.update_with_media', the interpreter crashs.

~~ ruby
class WelcomeController < ApplicationController
  def upload
    Twitter.update_with_media("I'm tweeting with gem!", File.new('screenshot.png'))
  end
~~

it doesn't crash when I use 1.9.2. or 1.9.3dev without rails.
You can reproduse this situation to

 1. create new rails 3.1.3 projects
 2. add gem 'twitter' in your Gemfile
 3. configure twitter consumer key, secret and oauth token, secret in your config/initializers
 4. make the action WelcomeController#upload and route it to POST /upload
 5. run the server and access POST /upload


-- 
http://redmine.ruby-lang.org