Akira Tanaka <akr / fsij.org> wrote:
> A problem of this proposal is the method name.
> Tempfile.open2 is not a good name.

Since Tempfile.new already takes an optional hash,
how about:

  Tempfile.open(..., finalizer: false)