On 2011-12-04, at 16:15:00, Alexey Muranov wrote:
>=20
> But what is wrong with having one class instead of two, if internally =
they behave mostly the same, and one literal notation instead of two? =
Anyway, this was just an idea.

Hash tables aren't Sets, nor the other way around. I'd like to avoid =
messing up data structure definitions any more than they already are.

The only compelling reason for bringing Set into core would be a literal =
syntax =96 and I agree, as a data structure it would be a useful =
addition and encourage its usage =96 but I don't really have anything to =
contribute to the particular bikeshed of syntax thereof.