Hi,

In message "Re: [ruby-core:41183] [ruby-trunk - Feature #5653] "I strongly discourage the use of autoload in any standard libraries" (Re: autoload will be dead)"
    on Tue, 22 Nov 2011 09:57:54 +0900, jonathan rochkind <jonathan / dnil.net> writes:

|My understanding was that plain old 'require' had much the same flaw in a multi-threaded environment as autoload. No?

Since calling #require is explicit, there's plenty of chance to manage
them.  Introducing single lock for #require loading is another issue.

							matz.