Hello,

2011/11/11 Luis Lavena <luislavena / gmail.com>:
> These gems depends on 3rd party libraries (OpenSSL, libxml2) which,
> under the environment I'm worried about (Windows) are not present by
> default.
>
> This increases the burden on gem authors to compile binaries for every
> new API version of Ruby.

Sorry I cannot get your point yet.¡¡Gem developer already has both
developement environment and knowledge for building his/har gems.
So why does the burden increase in comparison to a simple gem?


> For every new Ruby version that changes ABI, gem authors will require
> to release a newer binary that either bundles all the supported
> versions of Ruby for his gem or drop those versions from the
> dependency.

Yes.  This proposal increases the task of all gem developers.

I know no one will be happy to have extra work.  But I think that
it is too unhappy for the core team to ensure ABI compatiblility.
So I'm searching another way to share the pain with gem authors.


> I believe what Eric will address is the be able to define a dependency
> under which Ruby you can install certain gem.
>
>>
>>> While 1.8.x usage has been reduced lately, it is still present.
>>
>> Slightly off topic, 1.8 will be dying when 2.0.0 is released.
>> (2.0.0 will be released at Feb. 2013, and 1.8 will be abandoned
>> at June 2013)  So I don't feel like caring about 1.8.
>>
>
> 1.8 is just an example, instead of 1.8 it will be come 1.9.1 versus
> 2.0.0 versus 2.0.1

I know.  It is just off topic.

Thanks!

-- 
Yusuke Endoh <mame / tsg.ne.jp>