--Ns7jmDPpOpCD+GE/
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

V=EDt Ondruch escreveu isso a=ED:
> Dne 1.11.2011 0:05, Eric Hodel napsal(a):
> >On Oct 31, 2011, at 2:41 PM, V=EDt Ondruch wrote:
> >>Actually you have missed that there are Linux distros, which are repack=
aging the gems. I am speaking of Fedora and RHEL. It would cause a lot of t=
roubles.
> >What troubles?
>=20
> Because you had to rebuild packaged gems after even the tiniest
> update of Ruby. There is currently more then 200 gems in Fedora, so
> that is a lot of work to rebuild them. Even the smallest Rails stack
> counts almost 50 gems.

Same for Debian. But the rebuild is automated and it is supposed to be
needed once a year, so it's probably ok-ish from a Debian POV.

A minor point: breaking ABI on changes to the third component of a
version number is somehow counter-intuitive, and it would be nice if
these ABI-breaking versions were 2.1.x, 2.2.x, 2.3.x, ... instead of
2.0.1, 2.0.2, 2.0.3, ...

This is how Python (2.7.x, 2.8.x, ...) and Perl (5.10.x, 5.12.x,
5.14.x,) do it.

--=20
Antonio Terceiro <terceiro / softwarelivre.org>
http://softwarelivre.org/terceiro



--Ns7jmDPpOpCD+GE/
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk66YFAACgkQDOM8kQ+cso+v5QCfUTqwPIO8tpl8AVY1+te0t5Ww
NC4An1MHnD4EtQSwbHTfeHV73piHpxoj
=AlLb
-----END PGP SIGNATURE-----

--Ns7jmDPpOpCD+GE/--