Issue #5555 has been updated by markus heiler.


I am neutral on it, not pro, not con. But I think a simple alias could suffice here?

It is often a quite general question on english grammar too.

For instance, on class String I was using #starts_with? rather than #start_with?

But I think both should be equivalent.

  "foo".starts_with? 'f' # => true
  "foo".start_with? 'f'  # => true
----------------------------------------
Feature #5555: rename #include? to #includes?
http://redmine.ruby-lang.org/issues/5555

Author: Alexey Muranov
Status: Open
Priority: Normal
Assignee: 
Category: 
Target version: 


Shouldn't the #include? method be renamed to #includes? ?
I think this will be closer to correct English and consistent with #has_key? method (not #have_key?).


-- 
http://redmine.ruby-lang.org