Issue #5450 has been updated by Hiroshi Nakamura.

Priority changed from Urgent to Normal
Target version changed from 1.9.3 to 1.9.x

0.9.2.2 is pushed to rubygems.org at 22 Oct. Now it's not a release blocker for 1.9.3 and I changed the priority to 'Normal'.

For 2.0.0, this issue should be solved at #5481. For 1.9.3-pX, we still need a care.
----------------------------------------
Bug #5450: rake 0.9.2.2 does not exist in rubygems.org
http://redmine.ruby-lang.org/issues/5450

Author: Hiroshi Nakamura
Status: Open
Priority: Normal
Assignee: Hiroshi Nakamura
Category: lib
Target version: 1.9.x
ruby -v: ruby 1.9.3dev (2011-09-23 revision 33323) [x86_64-linux] 


1.9.3 installs rake as a 'default gems' which version is 0.9.2.2, but the version does not exist in RubyGems's source repository.

I heard that it makes bundler confuse. For some environment (not 100%), bundler generates Gemfile.lock with 'rake 0.9.2.2' and it crashes because it's not in rubygems.org.

1) create the following 2-lines Gemfile
     source :rubygems
     gem "rake"

2) bundle install

It creates '0.9.2.2' Gemfile.lock for some environment. (gem cache related? I'm not sure at present)

It might be just a bug of somewhere (ruby, rubygems, bundler, etc.), and should be fixed, but I think that this is an issue about "importing third party's gem as a standard library". It would be happened for json as well in the future.

I propose to remove 'rake' from 'default gems' for 1.9.3 GA (It just works as same as before like other standard libraries.) And the next version (1.9.4 or 2.0) should have a better way to integrate.

Thoughts?


-- 
http://redmine.ruby-lang.org