Issue #5387 has been updated by Eric Hodel.


I think this should block 1.9.3, RubyGems should not add a new top-level module.

I can fix this on Monday.
----------------------------------------
Bug #5387: Deprecate should be Gem::Deprecate
http://redmine.ruby-lang.org/issues/5387

Author: Gregory Brown
Status: Assigned
Priority: Normal
Assignee: Eric Hodel
Category: 
Target version: 1.9.3
ruby -v: ruby 1.9.3dev (2011-09-23 revision 33323) [x86_64-darwin10.7.3]


On Ruby 1.9.3.rc1, Deprecate is defined at the top level. Unless this is meant to be used outside of RubyGems, it should be moved into the RubyGems namespace.



-- 
http://redmine.ruby-lang.org