On 29 September 2011 14:51, Shyouhei Urabe <shyouhei / ruby-lang.org> wrote:
>
> Issue #4996 has been updated by Shyouhei Urabe.
>
>
> =3Dbegin
>
> Hi folks, I'd like to make an official announcement about this topic on w=
ww.ruby-lang.org.
> Can you take a look at this draft? =A0I'm sure my English is bad.
>
>
> =A0 =A0Hello, and thank you for your getting into our community.
>
> =A0 =A0I know most of =A0you more or less use version 1.8.7 =A0of Ruby to=
day. =A0It
> =A0 =A0was released =A0in 2008 and was =A0a state-of-art Ruby =A0release =
back then.
> =A0 =A0-- I am =A0proud to say =A0it is no =A0longer. =A0Ruby's core =A0d=
evelopers have
> =A0 =A0been actively working =A0on their new versions, 1.9, =A0and they a=
re about
> =A0 =A0to =A0release new 1.9.3. =A0 I have =A0been using =A01.9 for =A0ye=
ars and =A0now I
> =A0 =A0cannot =A0go =A0back to =A0the =A0days =A0without =A0it. =A0Rich =
=A0features. =A0 Faster
> =A0 =A0execution. =A0Rubygems integrated. =A0Rails works perfectly. =A0I =
cannot but
> =A0 =A0say it is totally wonderful. =A0Everyone please, use 1.9.
>
> =A0 =A0But at =A0the same time I =A0know you cannot =A0switch to 1.9 righ=
t =A0now for
> =A0 =A0various =A0reasons. =A0 =A0Maybe =A0you =A0 have =A0already =A0bee=
n =A0 deployed =A0your
> =A0 =A0application with 1.8.7. =A0Maybe you use a 3rd party library and t=
hat is
> =A0 =A0for 1.8.7 only. =A0Or maybe your Linux distribution only supports =
1.8.7.
> =A0 =A0So I hereby announce =A0you how long you can stick to =A0it. =A0It=
 is OK you
> =A0 =A0are using 1.8.7 today but after a while, it will be shut down.
>
> =A0 =A0Please be ready.
>
> =A0 =A0Schedule:
>
> =A0 =A0* We continue to provide normal =A0maintenance for 1.8.7 as usual,=
 until
> =A0 =A0 =A0June =A02012. =A0 You can =A0safely =A0assume =A0we =A0provide=
 bugfixes =A0and =A0no
> =A0 =A0 =A0incompatibility shall be introduced.
>
> =A0 =A0* After that we stop bugfixes. =A0 We still provide security fixes=
 until
> =A0 =A0 =A0June 2013, in case you are still using 1.8.7.
>
> =A0 =A0* We will no longer support 1.8.7 in all senses after June 2013.

I am not a native english speaker, but here is what I think.

I believe what you wrote is actually really good english and entertaining.

I found only one sentence which is a bit unclear:
"Ruby's core developers have been actively working  on their new
versions, 1.9,  and they are about to release new 1.9.3."
I would rather write:
"Ruby's core developers have been actively working  on their new
version, 1.9, and they are about to release 1.9.3."

Benoit Daloze