Issue #5135 has been updated by Vit Ondruch.


Motohiro KOSAKI wrote:
> > Actually I am building Ruby 1.9.3 from SRPM [1] in mock, i.e. using Koji [2]. Here [3] you can see the build output and the build failures (note that the output slightly differs, since the test are not stable for some reason I don't understand).
>  >
>  > Also note that I am actually executing the test suite after "make install" as you can see either from the log [3] or from spec file [4], however it does not mean that the newly installed Ruby becomes available in the $PATH, which is probably what you expect.
>  
>  Yup, I expected.
>  I think following two test failure indicate such issue. This is hard
>  to fix properly because Webrick is micro web server. and adding
>  careless knob for loading another executable files
>  might make security issue in future.
>  
>  Therefore I hope you avoid this issue by your test environment craft.
>  
>  
>   51) Failure:
>  test_cgi(TestWEBrickCGI)
>  [/builddir/build/BUILD/ruby-1.9.3-preview1/test/webrick/test_cgi.rb:33]:
>  webrick log start:
>    [2011-08-04 08:47:33] INFO  WEBrick 1.3.1
>    [2011-08-04 08:47:33] INFO  ruby 1.9.3 (2011-07-31) [x86_64-linux]
>    [2011-08-04 08:47:33] INFO  WEBrick::HTTPServer#start: pid'133 portR289
>    [2011-08-04 08:47:33] ERROR CGIHandler:
>  /builddir/build/BUILD/ruby-1.9.3-preview1/test/webrick/webrick.cgi:
>    /builddir/build/BUILD/ruby-1.9.3-preview1/ruby: error while loading
>  shared libraries: libruby.so.1.9: cannot open shared object file: No
>  such file or directory
>    [2011-08-04 08:47:33] ERROR CGIHandler:
>  /builddir/build/BUILD/ruby-1.9.3-preview1/test/webrick/webrick.cgi
>  exit with 127
>    [2011-08-04 08:47:33] ERROR Premature end of script headers:
>  /builddir/build/BUILD/ruby-1.9.3-preview1/test/webrick/webrick.cgi
>  
>  webrick log end.
>  <"/webrick.cgi"> expected but was
>  <"<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.0//EN\">\n<HTML>\n
>  <HEAD><TITLE>Internal Server Error</TITLE></HEAD>\n  <BODY>\n
>  <H1>Internal Server Error</H1>\n    Premature end of script headers:
>  /builddir/build/BUILD/ruby-1.9.3-preview1/test/webrick/webrick.cgi\n
>   <HR>\n    <ADDRESS>\n     WEBrick/1.3.1 (Ruby/1.9.3/2011-07-31)
>  OpenSSL/1.0.0d at\n     127.0.0.1:52289\n    </ADDRESS>\n
>  </BODY>\n</HTML>\n">.
>   52) Failure:
>  test_script_disclosure(WEBrick::TestFileHandler)
>  [/builddir/build/BUILD/ruby-1.9.3-preview1/test/webrick/test_filehandler.rb:264]:
>  webrick log start:
>    [2011-08-04 08:47:47] INFO  WEBrick 1.3.1
>    [2011-08-04 08:47:47] INFO  ruby 1.9.3 (2011-07-31) [x86_64-linux]
>    [2011-08-04 08:47:47] INFO  WEBrick::HTTPServer#start: pid'133 portR263
>    [2011-08-04 08:47:47] ERROR CGIHandler:
>  /builddir/build/BUILD/ruby-1.9.3-preview1/test/webrick/webrick.cgi:
>    /builddir/build/BUILD/ruby-1.9.3-preview1/ruby: error while loading
>  shared libraries: libruby.so.1.9: cannot open shared object file: No
>  such file or directory
>    [2011-08-04 08:47:47] ERROR CGIHandler:
>  /builddir/build/BUILD/ruby-1.9.3-preview1/test/webrick/webrick.cgi
>  exit with 127
>    [2011-08-04 08:47:47] ERROR Premature end of script headers:
>  /builddir/build/BUILD/ruby-1.9.3-preview1/test/webrick/webrick.cgi
>  
>  webrick log end.
>  <"200"> expected but was
>  <"500">.

No matter what I am trying, the environment LD_LIBRARY_PATH environment variable is not propagated deep enough and I still get the error. Could help me please?
----------------------------------------
Bug #5135: Ruby 1.9.3-preview1 tests fails in Fedora Rawhide
http://redmine.ruby-lang.org/issues/5135

Author: Vit Ondruch
Status: Closed
Priority: Normal
Assignee: Motohiro KOSAKI
Category: 
Target version: 1.9.3
ruby -v: -


It would be nice if all test are green before release.

https://gist.github.com/1118196


-- 
http://redmine.ruby-lang.org