Issue #5313 has been reported by Vit Ondruch.

----------------------------------------
Feature #5313: Please drop IRB's version in favour of Ruby version
http://redmine.ruby-lang.org/issues/5313

Author: Vit Ondruch
Status: Open
Priority: Normal
Assignee: 
Category: 
Target version: 


It seems that IRB's upstream lives in Ruby's SVN. There is no way how to update IRB separate from Ruby. From that point of view, it would make sense to drop IRB's own version numbers in favour of Ruby versions instead. The IRB reports this version information:

> irb -v
irb 0.9.6(09/06/30)

However from the IRB changelog [1] it is clear that there went some changes in meantime, so the IRB's versioning is not reliable and does not make a sense IMO.


[1] https://github.com/ruby/ruby/commits/trunk/lib/irb


-- 
http://redmine.ruby-lang.org