Charlie Savage <cfis / savagexi.com> wrote:
> Issue #5306 has been updated by Charlie Savage.

> Hmm, I take is this is against head?  On the 1.9.3 branch there is
> already this method (line 2384):

It should apply cleanly to r33236 (ruby_1_9_3)

> void
> rb_fd_copy(rb_fdset_t *dst, const fd_set *src, int max)
> 
> The patch then adds this right below it (line 2399):
> 
> static void
> rb_fd_rcopy(fd_set *dst, rb_fdset_t *src)

The new function is "rcopy" (reverse copy).  I named it based on memrchr()
vs memchr().  Maybe someone can think of a better name?