> これは 1.9.3 にバックポートしても良いですか?

以下はどのくら深刻なのでしょうか。


>  1 & 1.5 がエラーになるので、
>  1 & Rational(3,2)
>  
>  1 & BigDecimal('1.5')
>  もエラーにすべきかもしれません。

freeze 後に仕様変更的な修正を入れるのは可能なら避けたいという思いがあります。
もし仮に修正漏れがあり、1.9.4で再fixとなると、エンドユーザ視点では1.9.2, 1.9.3, 1.9.4で
それぞれ微妙に挙動が異なることになり迷惑だからです。

しかし、1) 修正に自信がある、または 2) 重要度的に外せれない ということであれば反対はしません。