Issue #5225 has been reported by Andrew Selder.

----------------------------------------
Bug #5225: Coverage blowing up
http://redmine.ruby-lang.org/issues/5225

Author: Andrew Selder
Status: Open
Priority: Normal
Assignee: 
Category: 
Target version: 
ruby -v: 1.9.2-p290


I just ran into a situation where the coverage tool in Ruby 1.9 is blowing up

It's a fairly easily reproducible test case:
Start irb, require 'coverage', Coverage.start, require 'eBayAPI', boom

The internal VM bug report can be seen in this Gist: https://gist.github.com/1168728

System Specs (OS X 10.7, Ruby 1.9.2-p290 via rvm, eBay gem v 1.1)


-- 
http://redmine.ruby-lang.org