--MW5yreqqjyrRcusr
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Mon, Aug 08, 2011 at 11:02:45PM +0900, Naohisa Goto wrote:
>=20
> Issue #5168 has been reported by Naohisa Goto.
>=20
> ----------------------------------------
> Bug #5168: libc and libm path in test/dl and test/fiddle on Solaris
> http://redmine.ruby-lang.org/issues/5168
>=20
> Author: Naohisa Goto
> Status: Open
> Priority: Normal
> Assignee: Aaron Patterson
> Category:=20
> Target version:=20
> ruby -v: ruby 1.9.3dev (2011-08-08) [sparc-solaris2.10]
>=20
>=20
> In test/dl/test_base.rb, "libc.so.6" and "libm.so.6" are used for Solaris=
, but sparc Solaris only have libc.so.1 and libm.so.2.
> I don't know what version number on Intel x86 Solaris, so I simply remove=
d the version numbers. (file test-dl-libc-solaris.patch)
>=20
> Similar code is found in test/fiddle/test_base.rb, but no code for Solari=
s.
> Patch attached. (file test-fiddle-libc-solaris.patch)

Yes, feel free to commit this.  :-)

--=20
Aaron Patterson
http://tenderlovemaking.com/

--MW5yreqqjyrRcusr
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (Darwin)

iQEcBAEBAgAGBQJOQFF4AAoJEJUxcLy0/6/GbLgH/Rg74okgiegvzoJceRxGV/VY
cu6b4agKGOHg8mkfWSiHWn0HepWfTSOmnfmJ5yMEXWp7PU5U4vUTJm3WDdtBUkGW
xU6DgLp/vLmifNGa2wAyUtcDFQzQmjRA3X7KHTfY2Cg1u/5KrtEtahkm9qL3AF56
wwMvP2/nmDBHfpUx8M0k7+9f6w1j/MlyMibuXhe73E6LLBvkgY3pz/ySsZov2eF1
eE1eXJ70uR1I4zFAhR8pemz2ZAR8QRL9M75z4eHA7jWG0gtL0fqVoncaPdPCjKnp
fLY1wLOYAon8zIPBCMUSfbZc5/VNXPzUtmy+aFVpTJgLw/C2uNn99JQAEL6nArE=
=r4t2
-----END PGP SIGNATURE-----

--MW5yreqqjyrRcusr--

On Mon, Aug 08, 2011 at 11:02:45PM +0900, Naohisa Goto wrote:
>=20
> Issue #5168 has been reported by Naohisa Goto.
>=20
> ----------------------------------------
> Bug #5168: libc and libm path in test/dl and test/fiddle on Solaris
> http://redmine.ruby-lang.org/issues/5168
>=20
> Author: Naohisa Goto
> Status: Open
> Priority: Normal
> Assignee: Aaron Patterson
> Category:=20
> Target version:=20
> ruby -v: ruby 1.9.3dev (2011-08-08) [sparc-solaris2.10]
>=20
>=20
> In test/dl/test_base.rb, "libc.so.6" and "libm.so.6" are used for Solaris=
, but sparc Solaris only have libc.so.1 and libm.so.2.
> I don't know what version number on Intel x86 Solaris, so I simply remove=
d the version numbers. (file test-dl-libc-solaris.patch)
>=20
> Similar code is found in test/fiddle/test_base.rb, but no code for Solari=
s.
> Patch attached. (file test-fiddle-libc-solaris.patch)

Yes, feel free to commit this.  :-)

--=20
Aaron Patterson
http://tenderlovemaking.com/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (Darwin)

iQEcBAEBAgAGBQJOQFF4AAoJEJUxcLy0/6/GbLgH/Rg74okgiegvzoJceRxGV/VY
cu6b4agKGOHg8mkfWSiHWn0HepWfTSOmnfmJ5yMEXWp7PU5U4vUTJm3WDdtBUkGW
xU6DgLp/vLmifNGa2wAyUtcDFQzQmjRA3X7KHTfY2Cg1u/5KrtEtahkm9qL3AF56
wwMvP2/nmDBHfpUx8M0k7+9f6w1j/MlyMibuXhe73E6LLBvkgY3pz/ySsZov2eF1
eE1eXJ70uR1I4zFAhR8pemz2ZAR8QRL9M75z4eHA7jWG0gtL0fqVoncaPdPCjKnp
fLY1wLOYAon8zIPBCMUSfbZc5/VNXPzUtmy+aFVpTJgLw/C2uNn99JQAEL6nArE=
=r4t2
-----END PGP SIGNATURE-----