On Jul 27, 2011, at 17:50, Jeremy Evans <merch-redmine / jeremyevans.net> wrot=
e:

>>> Even with the attached patch, there are 5 failures. 3 failures are weird=
 linking errors in the rake tests I don't understand ("ruby lib version (1.9=
.3) doesn't match executable version (1.9.4)").
>>=20
>> Hmm, I don't know about it.
>=20
> This appeared to be caused by my use of a non-pristine checkout.  I did a p=
ristine checkout and they went away.

This may occur for certain tests if ./ruby is not the same version as the ru=
by in $PATH when a test invokes ruby in a forked process. It's a test bug I c=
an reproduce but haven't filed a ticket for. You can ignore it.=20=