Issue #5097 has been updated by Jeremy Evans.

File ruby193.log added
File ruby193.diff added

Attached is the make check output on OpenBSD amd64.  I'm also attaching a diff with the patches I used:

* bootstraptest/test_thread.rb: Skip 2 tests. The first one appears to hang, the second crashes with a sigaltstack error.

* configure: Use -pthread instead of -lpthread when linking.  From OpenBSD man pages: "On OpenBSD, the -pthread option should be used to link threaded code, isolating the program from operating system details."

  Use OpenBSD shared library naming convention (libruby19.so.1.0, as 1.9.2 used libruby19.so.0.0).

  Don't include OpenBSD version number in $arch.  OpenBSD version numbers do not have any relationship to API/ABI compatibility.

* ext/socket/lib/socket.rb: Don't check ipv6_recvpktinfo. This fixes a failure in one of the socket tests:

    test_udp_server(TestSocket):
    RuntimeError: no response from #<Addrinfo: fe80::92fb:a6ff:feed:afa1%re0>

* test/fileutils/test_fileutils.rb: Add openbsd to the /freebsd|netbsd/ regexp.  Fixes:

    test_chmod_symbol_mode(TestFileUtils):
    Errno::EFTYPE: Inappropriate file type or format - tmp/a

* test/ruby/test_process.rb: Add openbsd to the /freebsd/ regexp.  Fixes:

    test_wait_and_sigchild(TestProcess) [/usr/obj/ports/ruby-1.9.3-p0/ruby-1.9.3-p0/test/ruby/test_process.rb:1205]:
     [ruby-core:19744].
    <[true]> expected but was
    <[true, true]>.

  Skip test_rlimit_nofile as it appears to hang.

Even with the attached patch, there are 5 failures. 3 failures are weird linking errors in the rake tests I don't understand ("ruby lib version (1.9.3) doesn't match executable version (1.9.4)").  2 failures appear to be caused by using GNU make syntax in the makefiles.  On 1.9.2, BSD make was able to work with the makefiles, but starting on 1.9.3, it appears GNU make is required.  Either makefiles should use not use GNU extensions or ruby should use gmake instead of make on BSD systems.

I used a modified version of the OpenBSD port for 1.9.2 to build 1.9.3, using a tarball created from b6fd481c of the git mirror (svn revision 32655). The following configure environment was used:

LIBruby19_VERSION=1.0 PREFIX="/usr/local"  CPPFLAGS="-DOPENSSL_NO_STATIC_ENGINE -I/usr/local/include"  LDFLAGS="-L/usr/local/lib" CONFIG_SITE='/usr/ports/infrastructure/db/config.site' MKDIR_P='mkdir -p' MAKE=gmake PATH=/usr/obj/ports/ruby-1.9.3-p0/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/bin:/usr/X11R6/bin

and the following configure arguments:

--program-suffix=19  --with-soname=ruby19  --enable-pthread  --enable-ipv6  --disable-option-checking --with-tcl-include=/usr/local/include/tcl8.5  --with-tk-include=/usr/local/include/tk8.5  --with-X11-dir=/usr/X11R6 --enable-shared --prefix='/usr/local' --sysconfdir='/etc' --mandir='/usr/local/man' --infodir='/usr/local/info' --disable-silent-rules

----------------------------------------
Feature #5097: Supported platforms of Ruby 1.9.3
http://redmine.ruby-lang.org/issues/5097

Author: Yui NARUSE
Status: Assigned
Priority: Normal
Assignee: Yui NARUSE
Category: 
Target version: 1.9.3


Let's decide the supported platforms.

== Background

http://redmine.ruby-lang.org/projects/ruby-19/wiki/SupportedPlatforms

== Process

If you want to support a platform, please declare.
But when a platform dependent bug is reported, it will be assigned to you.

== Current Maintainer

mswin32, mswin64 (Microsoft Windows):
  NAKAMURA Usaku (usa)
mingw32 (Minimalist GNU for Windows):
  Nobuyoshi Nakada (nobu)
IA-64 (Debian GNU/Linux):
  TAKANO Mitsuhiro (takano32)
Symbian OS:
  Alexander Zavorine (azov)
AIX:
  Yutaka Kanemoto (kanemoto)
FreeBSD:
  Akinori MUSHA (knu)
Solaris:
  Naohisa Goto
RHEL, CentOS
  KOSAKI Motohiro

Platforms which doesn't have a maintainer are following:
* Debian
* Ubuntu
* Mac OS X (LLVM related issues)
* cygwin (don't work)
* NetBSD (works)
* OpenBSD (it may not work)
* DragonFlyBSD (don't work)


-- 
http://redmine.ruby-lang.org