On Sat, Jul 23, 2011 at 23:09, Eric Wong <normalperson / yhbt.net> wrote:
> Brian Candler <b.candler / pobox.com> wrote:
>> I'm a lone voice in the wilderness
>
> You're not alone, I don't like the 1.9 encoding system, either; but
> I primarily deal with binary data so I don't usually need to care about it
> other than setting binmode on $std{in,out,err}

You're not alone.

Everybody hates encoding issues. Ruby 1.9 just forces you to deal with
them, while 1.8 silently ignores them.