On Wed, 24 Nov 2004 nobu.nokada / softhome.net wrote:
> Johan Holmberg wrote in [ruby-core:03692]:
>> I just tried to compile some old revisions of Ruby, by checking out
>> from CVS how the source looked at a particular time. But it seems
>> like all revisions between 2004-04-28 and 2004-10-31 fail to
>> compile.
>>
>> This seems very strange to me. Can anyone explain what is going on?
>> (I hope I'm missing something obvious, but just now I can't see what
>> I'm doing wrong ...)
>
> A cvs 1.11.x issue.  It ignores default branches in the past.
>

Thanks for the reply.
But I don't understand the implications.

I tried to download and build CVS 1.12.10 and checkout the Ruby 
source with that new CVS client. No difference as far as I can tell 
(I did a "diff -r" on the old and new checkouts and they were 
identical).

Do you mean that the server would be required to run a better 
version than 1.11.x ? Would that fix this problem ?

Or should a better version than 1.11.x have been used when the 
import of the Oniguruma code was done recently. If this is the case, 
does it mean that it is "too late" now ?

/Johan Holmberg