2011/7/17 Thomas Sawyer <transfire / gmail.com>:
> Hi, thanks for example. I may not fully understand bsearch, but basically=
 what I mean is that if finding minimum value is the important thing, then =
why not call it #find_minimum ? (and what about #find_maximum ?). But if bi=
nary search is what is important than could not a #beach (b-each) be combin=
ed with a variety of uses.

I understand you.  In principle, a method name should not represent
how it does but what it does.
But in this case, the feature has a strict pre-condition: the array
must be sorted.  So, the name #find_minimum is too generic.
We may call it #find_minimum_from_sorted_array or so, but I believe
#bsearch is more suitable.

--=20
Yusuke Endoh <mame / tsg.ne.jp>