Issue #1136 has been updated by Eric Hodel.

Category set to lib
Status changed from Open to Closed
Target version set to 1.9.3

I cannot reproduce:

$ gem19 install rails -i ~/tmp/gems
???
24 gems installed
$ GEM_HOME=~/tmp/gems ri19 Kernel#require

Kernel#require

(from ruby core)
???
$ GEM_HOME=~/tmp/gems ri19 --version
ri19 3.8
$ ruby19 --version
ruby 1.9.3dev (2011-07-07 trunk 32428) [x86_64-darwin10.8.0]

----------------------------------------
Feature #1136: "ri Kernel#require" is broken
http://redmine.ruby-lang.org/issues/1136

Author: Jeremy Henty
Status: Closed
Priority: Normal
Assignee: Eric Hodel
Category: lib
Target version: 1.9.3
ruby -v: ruby 1.8.7 (2008-08-11 patchlevel 72) [i686-linux]


=begin
 $ ri Kernel#require
 More than one method matched your request. You can refine
 your search by asking for information on one of:
 
      Kernel#require, Kernel#rescue_require, Kernel#require
 
 Now what do I do to see the Kernel#require documentation?
=end



-- 
http://redmine.ruby-lang.org